Skip to content
MNIST Neural Network
Profile icon
SpencerMarich

Neural Network designed around the MNIST dataset.
Made with tensorflow and keras.

You are viewing a single comment. View All
Profile icon
Identity-Unknown

bruh error ):
Python 3.8.2 (default, Feb 26 2020, 02:56:10)

Replit: Updating package configuration

--> python3 -m poetry init --no-interaction --name repl_python3_4G8R6PpcSHu

This command will guide you through creating your pyproject.toml config.

You can specify a package in the following forms:

--> python3 -m poetry add tensorflow
Using version ^2.8.0 for tensorflow

Updating dependencies
Resolving dependencies...

SolverProblemError

The current project's Python requirement (>=3.8,<4.0) is not compatible with some of the required packages Python requirement:
- tensorflow-io-gcs-filesystem requires Python >=3.7, <3.11, so it will not be satisfied for Python >=3.11,<4.0
- tensorflow-io-gcs-filesystem requires Python >=3.7, <3.11, so it will not be satisfied for Python >=3.11,<4.0

Because no versions of tensorflow-io-gcs-filesystem match >0.23.1,<0.24.0 || >0.24.0
and tensorflow-io-gcs-filesystem (0.23.1) requires Python >=3.7, <3.11, tensorflow-io-gcs-filesystem is forbidden.
And because tensorflow-io-gcs-filesystem (0.24.0) requires Python >=3.7, <3.11, tensorflow-io-gcs-filesystem is forbidden.
Because no versions of tensorflow match >2.8.0,<3.0.0
and tensorflow (2.8.0) depends on tensorflow-io-gcs-filesystem (>=0.23.1), tensorflow (>=2.8.0,<3.0.0) requires tensorflow-io-gcs-filesystem (>=0.23.1).
Thus, tensorflow is forbidden.
So, because repl-python3-4g8r6ppcshu depends on tensorflow (^2.8.0), version solving failed.

at /opt/virtualenvs/python3/lib/python3.8/site-packages/poetry/puzzle/solver.py:241 in _solve
237│ packages = result.packages
238│ except OverrideNeeded as e:
239│ return self.solve_in_compatibility_mode(e.overrides, use_latest=use_latest)
240│ except SolveFailure as e:
→ 241│ raise SolverProblemError(e)
242│
243│ results = dict(
244│ depth_first_search(
245│ PackageNode(self._package, packages), aggregate_package_nodes

• Check your dependencies Python requirement: The Python requirement can be specified via the python or markers properties

For tensorflow-io-gcs-filesystem, a possible solution would be to set the `python` property to ">=3.8,<3.11" For tensorflow-io-gcs-filesystem, a possible solution would be to set the `python` property to ">=3.8,<3.11" https://python-poetry.org/docs/dependency-specification/#python-restricted-dependencies, https://python-poetry.org/docs/dependency-specification/#using-environment-markers

exit status 1

Replit: Package operation failed.