Share your repls and programming experiences

← Back to all posts
Minecraft on Replit
SPQR

need I say more?
.
DISCLAIMER: It's a pain to log in and it's essentially unplayable due to the controls not working, but it actually runs ok on minimum settings. Hopefully future updates to the gfx here will allow it to work properly :))

EDIT: Yes, I know that shift doesn't work, and that you can't copy and paste your email in. Maybe try forking?

EDIT EDIT: it's for servers now cuz i accidentally redid the entire thing without forking
the original is here: https://repl.it/@SPQR/Minecraft

Voters
GurnieWare
MarcusVittori
shrekyboiboi
DepthStrider
Tonialg
RivanAgarwal
MichalPl
TurtleAndrew
LilCoder355
EllisEmms
Comments
hotnewtop
randomlylelo

took a solid 2 minutes to load, but the results are... beautiful

HarperframeInc

@randomlylelo It was faster for me,

ebest

Senātus Populusque Rōmānus!

bonnym512

@ebest Why Did you say SPQR? That was a Roman Phrase?

ebest

@bonnym512 Yes. SPQR = Senātus Populusque Rōmānus!

bonnym512

@ebest I know, but you aren't Senatus Populusque Romanus. that is the creator of this.

ebest

@bonnym512 I know

VulcanWM
ebest

@medcho am i?

VulcanWM

IT DOES LOOK LIKE [email protected]

VulcanWM

TO BE HONEST,I LIKE THE GREEKS [email protected]

ebest

@medcho the greeks are more unorthodox, more fun. Also, democratic.

VulcanWM

TRUE
THAT IS WHY I LIKE THEM [email protected]

[deleted]

The copy-paste file doesn't work. I have tried typing the last makefile line in but it still doesn't do anything.
I can right click and click the paste button, but nothing appears.

Zavexeon

SPQR is the port master lol.

SPQR

@Zavexeon LMAO im putting that in my bio

DSACharlie

It is showing:

lsambrook

Hey I made a website, please go check it out and tell me some suggestions, ideas, or things to improve.: https://repl.it/@lsambrook/Website-2

AdCharity

@lsambrook ngl I think you tooke the whole styling scheme from w3 schools

MemeManHimself

@AdCharity They did I remember I used this style thing once lol

techgeek680

from the comments your game looks amazing, but I cant reach it. did you delete it?

SPQR

@techgeek680 Sadly yes, I didn't have Hacker plan for a bit so I had to delete a bunch of things to make room for new repls. This was just a port of plain old Minecraft, though, nothing special here.

techgeek680

oh. Well I just found out how to upvote and I'm gonna do it! @SPQR

CollinKunsman

When I try creating an account, it doesn't let me use the @ symbol.

ETHANSIAO

I'd love to play this, but I'm not able to use the @ sign for my login. Is it possible to fix this?

SPQR

@ETHANSIAO paste it into logins.txt, then paste it into the email field using right click (ctrl+v doesn't work) You'll also need to do it for any capital letters. If you want to have multiple things pasted, copy and paste the last line of the makefile into the replit shell (accessible using f1> open shell, or right click edit window > open shell) any time you update logins.txt

CullenDAvello

@SPQR caps lock works for capitals but not special characters

ETHANSIAO

@SPQR I'm still unable to use the @ sign at the moment, could you please share a screenshot with me about how to properly add special characters to login.txt?

minermaniac447

Wanted to try this out... but is there any way to have the logins file be replaced with a .env file? I don't really want all of replit to know my minecraft login, and I can't modify it because I don't really know how you're doing the login.

SPQR

@minermaniac447 i dunno how to do that tbh, but what i did is only put the special symbols and caps in logins.txt, then pasted it and edited where necessary

amasad

@SPQR what bugs do we need to fix to make this better in the future?

SPQR

@amasad Well, the main issue i noticed is a discrepancy with controls. I noticed that the issue I'm experiencing somewhat reminds me of an issue I would see if using a touchscreen. No matter how I move the mouse, the game seems to interpret it as moving towards the bottom right corner of the screen. The only cause for that that I could think of would be that the frontend sends mouse position to X incorrectly, i.e. instead of X seeing that the mouse moved in a certain direction, it only sees that the mouse sort of teleported somewhere that i would assume is down and to the right of the crosshair. Also, The keyboard input is working very strangely in that Minecraft only seems to recognize about 1 of every 10 key presses (For comparison, when I ran DOOM, it recognized pretty much all of them.) I also noticed that X (or at least Minecraft) seems to think that Right Alt is being constantly held down (i noticed this when i tried to rebind one of the controls to the L key and it instead bound to Right Alt.) Other than that, there's really just the QOL improvements of easier interaction with the clipboard in the X window, and/or somehow getting the SHIFT key to work (I can't type caps or symbols, hence why i need copy and paste)

I dont want to seem like i'm ragging on replit though, because frankly, I didn't even expect this to work at all, so just being able to get it to run is pretty awesome. :)

HarperframeInc

@amasad Also, can you make GFX work for repl.run

SPQR

@HarperframeInc I'd imagine they're working on it

KyleChoi

It refuses to connect.

kingdracorex

link does not work anymore

BraggerSphere11

Trash it's not even here

NehalRam

its taking forever to load

YasBul

your project is the best pro...

Rylan950

ummm...
I think it would be good, but now there's an error screen.
Wait....
this isn't an April Fool's joke, right?

locness3

Was this deleted?

Vurce

doesnt work anymore...

duck132912

Does this actually run minecraft?

SPQR

@duck132912 it used to, but i broke it :P

duck132912

@SPQR can you fix it?

SPQR

@duck132912 I can if you'd like, but don't get the idea that you'll be playing Minecraft on repl.it anytime soon. Due to the interface between the browser and repl.it servers, the game is entirely unplayable (the mouse doesn't act like it should, it's like playing PC minecraft with a touchscreen if you've ever done that.)

But I'm a nice guy if you really want to see it for yourself i can do it. :)

duck132912

@SPQR oh that bug, so the mouse pointer does not lock?

SPQR

@duck132912 Nope. Unfortunately I don't think there's any way to make it lock, because I don't think webpages are capable of capturing the mouse like that

Vurce

@SPQR please fix it! I would love to try it even if it doesnt properly work!

DSACharlie

@SPQR It actually does work because click This then click "Lock Pointer"

TheImagin33r

im scared for when it finishes loading. im using a chromebook XD

duck132912
yanovsky

Still preparing spawn area, at 0%

yanovsky

Mine took forever to load, and is still not loding

yanovsky

Why is this so slow?

SPQR

@yanovsky B/C it's running on a virtual machine which you are accessing remotely

AidenWaterman

the link to the original is a 404, here the original:
https://repl.it/@SPQR/Minecraft-on-Replit-2-Boogaloo
It is missing export DISPLAY=:0.0 so here is a fixed one
https://repl.it/@AidenWaterman/Minecraft-on-Replit-2-Boogaloo

ebest

@SPQR, Can you "PLEASE " 1000000 delete your Firefox browser because a lot of people in my school are using it and I "REALLY " 1000000^10000000000000000 (overflow error) don't want repl.it blocked. PLEASE?

-Ebest

SPQR

@ebest done

ebest

@SPQR Thank you!

ebest

@SPQR you saved me

SPQR

@ebest no problem, I know how it feels to be in that situation

ebest

@SPQR my mistake of telling other people about it. If only you replaced it with some message like "Gah! Firefox has crashed."

[deleted]

It stopped working today

locness3

What type of repl did you choose ?

kamalhasan

took around 5 minutes to load but it was amazing.
cant copy tho.

RobertoBean

...this does put a smile on my face