Skip to content
Sign upLog in
← Back to Community

How to use a custom node version

Profile icon
leon332157

I'm sure many people have complains about repl.it's node version being old.

What you can to is install node with npm, and specify the start a start script like so "node index.js".

You can also change the package.json file to use whatever node version you want.

You just need to make sure to do npm install if command isn't found.

You can see the repl for an example.

Voters
Profile icon
VanXodus
Profile icon
programmeruser
Profile icon
forceofyoda
Profile icon
EpicGamer007
Profile icon
frissyn
Profile icon
leon332157
Comments
hotnewtop
Profile icon
michael888

Hi, I think this no longer works? It runs but immediately crashes without errors. Or is it only a temporary replit issue?

Profile icon
RahulChoubey1

or run npx [email protected] index.js

Profile icon
alanchen12

ok ok fine