Skip to content
← Back to Community
css not working
Profile icon
CamelGuy

Hello. I am making a chat box for myself and my friends. When I run the html without css, I get what you see to the side. The same thing happens when I add any css to it. Any solutions on how to get the css to appear when the application is ran?

Answered by hyperupcall [earned 5 cycles]
View Answer
Voters
Profile icon
xavieromar1
Profile icon
MikaellaManalas
Profile icon
pinkjuice
Profile icon
CamelGuy
Comments
hotnewtop
Profile icon
hyperupcall

hi!

because that is an 'HTML, CSS, JS', repl, i would recommend removing the php declaration text and php code from your index.html; the php code will not work.

relevant to your styling issue, you reference your css as such:

<link rel='stylesheet' type='text/css' href='css/style.css' />

it does not work because you have no directory called css with a style.css in it.
you can fix it by creating a directory and placing your css in there, or renaming your href reference

you can use any of the options @Geocube101 mentioned to update your href (without changing the name of any files or creating any folders)

  • href='/style.css' and href='//style.css' work because your style.css is at the root of your directory

  • href='style.css' and href='./style.css' work because both your index.html and style.css file is in the same directory.

Profile icon
CamelGuy

@eankeen Thanks! It worked!

Profile icon
Geocube101

try

<link rel='stylesheet' type='text/css' href='/style.css' />

or

<link rel='stylesheet' type='text/css' href='style.css' />

just to be sure

<link rel='stylesheet' type='text/css' href='./style.css' />
Profile icon
CamelGuy

@Geocube101 Your suggestion was the same as eankeen's suggestion, so your solution worked too! I appreciate the help!