Skip to content
← Back to Community
can repl update node js?
Profile icon
ChezCoder

i am making a discord bot that requires nodejs ^12.0.0 but the version repl is using is 10.19.0. please update node!

Voters
Profile icon
DexieTheSheep
Profile icon
progameplayer27
Profile icon
FuyuriKawaii
Profile icon
Ssarkos
Profile icon
BattleMaple
Profile icon
StealthHydra179
Profile icon
ChezCoder
Comments
hotnewtop
Profile icon
MrEconomical

we've bugged the admins forever

Profile icon
ChezCoder

@MrEconomical lol, so the reason why is because discord.js in repl is 12.0.0 but they prob forgot to update nodejs which is currently in 10.19.0... discord removed the RichEmbed constructor and replaced it with MessageEmbed. Problem is, node not being in the right versions, nodejs still thinks it is RickEmbed, not MessageEmbed hence returning an error. how can one get so unlocky XD

Profile icon
ChezCoder

@MrEconomical are you good in discord.js? I am trying to create a discord bot but the RichEmbeds aren't working .

Profile icon
MrEconomical

@ChezCoder I don't have much experience with discord bots sorry

Profile icon
ChezCoder

@MrEconomical ahh its ok