Method placed inside object, function still doesn't work.
JoshBorthick (1)

Hi everyone,

Edit: (from here:
--Attributes of a bad question: does not include link to repl or does include code in a codeblock? This seems counter intuitive, but to follow this logic I have not placed my code in a codeblock.--

Edit: Ok, I get it now, it wants the repl link only:

I am given a challenge among two in JS Assignment 12: Methods, Loops, and the this Keyword.

Here's my input for trying to solve:
double: double(number) {
return number*2

The template I used is from here:
It's the first code block in the "Methods" section.

What other info than the instructions should I learn to do this?

Further Edit: I've tried a bunch of different ways, like:
mathHelpers.double: method() {
mathHelpers[double]: method() {
mathHelpers[double] = method() {
mathHelpers["double"]: method() {
mathHelpers["double"] = method() {
mathHelpers.double = method() {
and so forth. I would have googled it but I have no idea how to word the search. I'm not sure what I'm not doing right, or what right is.

Here is my error:
ReferenceError: exerciseOne is not defined
at eval (eval at n.evaluate (, <anonymous>:4:14)
at (
at n.execute (
at e.M as queueRunnerFactory
at e.execute (
at e.fn (
at (
at n.execute (

You are viewing a single comment. View All
JoshBorthick (1)

@Zavexeon what's ^w^?

So, what I've got should work just fine, but the assignment is not accepting it as an answer.