Skip to content
Sign upLog in
← Back to Community

Why does the shell keep saying command not found if i already installed the packages?

Profile icon
IvanMelobensky

This keeps happening to me every time I open repl, but I see my packages installed.

image

These are Python PIP packages

Voters
Profile icon
IvanMelobensky
Comments
hotnewtop
Profile icon
Coder100

as python doesn't have access to the root, what you install can only be used as a library (through import) and you can't actually use the cli portion of it.

Profile icon
IvanMelobensky

@Coder100
but cli actually works for me, it just asks to reinstall each time... okay... btw pythonanywhere allowed that in their consoles and I didn't have to reinstall each time, but they were blocking some requests so I decided to use this website.

Profile icon
Coder100

yeah well pythonanywhere isn't replit as you may know

@IvanMelobensky

Profile icon
IvanMelobensky

image

Profile icon
Wumi4

Are you sure that the package tcd has command tcd? Because not all Linux packages has the same command name as its name.

Profile icon
IvanMelobensky

@Wumi4
when I run it through my command line on windows, mac and pydroid app, it works and opens all the commands available in this package. And it happens every time I reinstall it, but not updating the page here.

Profile icon
IvanMelobensky

@Wumi4
I even tried installing homebrew, it worked, but after I restarted my browser it didn't help. I didn't mention it's python pip package*

Profile icon
IvanMelobensky

@Wumi4
when I do pip list, I don't see my packages there again... but I should