Which of these code styles looks better / is more common?
I'm making a vector library for myself that currently looks something like this:
But since I've been using it, I'm tempted to make a few changes that will leave the code looking like this:
Does this transition make any sense? I kinda like what I have right now, but wouldn't mind making these changes if it makes more sense.
I agree that
vec1.dot() looks nicer, but I fell like..- static operations like number two seems like it more closely adheres to...like...gah- best practices? maintainability? like not depending on inner workings? 🤷♂️ something??
I'm...gonna stop talking now.