Ask coding questions

← Back to all posts
Upgrade Required Node.js
h
realTronsi (927)

I'm working on a simple chat application. It works on localhost, but whenever I upload it into repl, it says "Upgrade Required".

Answered by Coder100 (19272) [earned 5 cycles]
View Answer
Comments
hotnewtop
Coder100 (19272)

Hello, hit ctrl+shift+s
and do: npm i node

This worked for me. Hopes this helps!

realTronsi (927)

@Coder100 didnt work for me unfortunately, are there any alternatives

realTronsi (927)

@Coder100 when you say "this worked for me" do you mean specifically for this repl? If so it may just be some school laptop restrictions messing up repl

Coder100 (19272)

hmm... strange, schools shouldn't be able to change repl.it's behavior, but you could also manually install node.js and manually drop in the shell file at the end. @realTronsi

realTronsi (927)

@Coder100 that problem seems to be fixed, but now I have a new problem where the websockets handshakes are failing because repl uses https, and im not sure how websockets would work on repl

VortyxDev (0)

What I found effective is that you change your port on your node.js application. :)

TheForArkLD (772)

This message isn't for update nodejs, this message is for upgrade server.

realTronsi (927)

@TheForArkLD this code works perfectly fine in localhost, so im not sure if its something with repl or what

realTronsi (927)

@TheForArkLD I know what the error is, but I just dont know how to fix it since it works fine in localhost

TheForArkLD (772)

@realTronsi sry idk...
i cant help you sry....
can i do collab with me?
this is my reflection...

TheForArkLD (772)

@realTronsi (i recommend use socket.io)

realTronsi (927)

@TheForArkLD sure I can collab, I've been focusing on websockets and such

TheForArkLD (772)

@realTronsi ok, can you make bash repl?

realTronsi (927)

@TheForArkLD I dont know any bash, Ive been focusing on javascript and web development lately :(

TheForArkLD (772)

@realTronsi you dont need code bash :)