Ask coding questions

← Back to all posts
Unable to install tensorflow
amanavakn (0)

currently, while installing tensorflow==2.4.1 from the packages, I am getting below error:

--> python3 -m poetry add tensorflow
Using version ^2.4.1 for tensorflow

Updating dependencies
Resolving dependencies...


Package operations: 1 install, 0 updates, 0 removals

  - Installing tensorflow (2.4.1)

[EnvCommandError]
Command ['/opt/virtualenvs/python3/bin/pip', 'install', '--no-deps', 'tensorflow==2.4.1'] errored with the following return code -9, and output: 
Collecting tensorflow==2.4.1

exit status 1


Repl.it: Package operation failed.

and if I try to install from the shell, it kills the process in between.

Does anybody know what's the problem and how can I fix it?

Comments
hotnewtop
[deleted]

I did pip install tensorflow in the console and it worked fine.

amanavakn (0)

@novaflippers what's your python version, and the installed tensorflow version

robowolf (549)

Sadly replit.com doesn't support Tensorflow.

OldWizard209 (1537)

this is probably because your GPU doesn't support TensorFlow. I always faced this problem and the best you can do is search online. But anyways, here are a few places that will help:
Tensorflow issue on GitHub,
on SO

Note: You can search these yourselves also :P. But I hope I helped.

[deleted]

@OldWizard209 GPU? They werent having issues running tensorflow, they were having trouble installing it.

amanavakn (0)

@novaflippers this is the hardest part bro, even installing in real pc too.

[deleted]

@amanavakn If your having so much trouble, you should use Google Colab. They provide free python data science enviorments and even provide GPU's/TPU's

OldWizard209 (1537)

yeah, bruh. If your GPU is not compatible, u can't install it. Tensorflow is for ML and that can sweat any computer tbh. Tensorflow's installation program is pretty crappy. Everyone faces the problem. @novaflippers

[deleted]

@OldWizard209 I know, but thats exactly why google colab is there.