Ask coding questions

← Back to all posts
Unable to install sympy.
ThomasSheumaker (4)

For my project I need to install sympy but I keep getting this error
"Package operations: 1 install, 0 updates, 0 removals

  • Installing sympy (1.7.1)

[EnvCommandError]
Command ['/opt/virtualenvs/python3/bin/pip', 'install', '--no-deps', 'sympy==1.7.1'] errored with the following return code -9, and output:
Collecting sympy==1.7.1
Using cached https://files.pythonhosted.org/packages/ff/69/b16fc81b939d3efdd0b552f2e3e54f7fa1423d0c320cced2e69e675dde26/sympy-1.7.1-py3-none-any.whl
Installing collected packages: sympy

exit status 1

Repl.it: Package operation failed."

Comments
hotnewtop
InvisibleOne (3003)

Try running pip install sympy in the shell

CalSch (4)

@InvisibleOne This didn't work for me, when I tried to install it in the shell it said:

Collecting sympy
Using cached https://files.pythonhosted.org/packages/aa/26/956fece0fc67a6c299557d22158503206d8f14b2e0acc2daf7f06c5f4721/sympy-1.8-py3-none-any.whl
Requirement already satisfied: mpmath>=0.19 in /opt/virtualenvs/python3/lib/python3.8/site-packages (from sympy) (1.2.1)
Installing collected packages: sympy
Killed