Ask coding questions

← Back to all posts
Problem using 'net/http' on ruby 2.50 -- can I upgrade ruby version?
h
realquadrant

I have the following error:

I believe this is because there is no longer request_uri it has been deprecated to something like request.uri or something.

Voters
realquadrant
Comments
hotnewtop
SixBeeps

Nix has a variety of Ruby packages across various versions if you're willing to take a few minutes to learn it. Just set up a Nix Repl, install the Ruby compiler you want to use, then run a Ruby script through the console.

Quick video walkthrough: https://www.youtube.com/watch?v=gItKAtedmq4

realquadrant

Thanks @SixBeeps