Ask coding questions

← Back to all posts
Linked video won't play
TheDarkSlayer

Hello All,

I am extremely new to coding. I'm teaching myself HTML. I just started my first project on here to practice, and I am trying to add a YouTube video. It appears on the page, but it won't play. I used the video tag, added the URL to the src attribute, and have a closing tag. What am I doing wrong? Halp!

Answered by CatR3kd [earned 5 cycles]
View Answer
Voters
SS-08RA-997933
Dadadams99
SUHASTADIPARTH1
TANMAYBAGADIA
TheDarkSlayer
Comments
hotnewtop
CatR3kd

You need to have the video downloaded in ogg/mp4 format onto the repl and then use videoexample.ogg for the url

TheDarkSlayer

Thank you! @CatR3kd

CatR3kd

Can you mark my answer as correct please? @TheDarkSlayer

RYANTADIPARTHI

Two things - Either copy embedded code from a video URL by right clicking on the video, or write this code - <video><source src=""</video>, in the file, put your video URL. Or you can hit the dots at the top, and get the video you want from your files, and link it in the src, where I showed the empty string.

Coder100

video tags have a (imo) misleading syntax, read more about it here

But this is a youtube video, and they have even more strange syntax.
So on that specific youtube video:

And click copy on that bottom embed, so now your HTML code is:

SUHASTADIPARTH1

SUHASTADIPARTH1

You should copy the embedded code from Youtube. and paste it into your HTML.

SUHASTADIPARTH1

Oh, it doesn't work because you have a youtube URL.

SUHASTADIPARTH1

If it still doesn't work, then you have the URL wrong.

SUHASTADIPARTH1

You should have the video tags like this

<video controls> <source src="file here"> </video>