Ask coding questions

← Back to all posts
I need help
Undertale015

my repl keeps on saying this on thew right side i have no clue what it even means,

  • Serving Flask app '' (lazy loading)
  • Environment: production
    WARNING: This is a development server. Do not use it in a production deployment.
    Use a production WSGI server instead.
  • Debug mode: off
  • Running on all addresses.
    WARNING: This is a development server. Do not use it in a production deployment.
  • Running on http://172.18.0.36:8080/ (Press CTRL+C to quit)
    Traceback (most recent call last):
    File "main.py", line 142, in <module>
    client.run(os.getenv('TOKEN'))
    File "/opt/virtualenvs/python3/lib/python3.8/site-packages/discord/client.py", line 723, in run
    return future.result()
    File "/opt/virtualenvs/python3/lib/python3.8/site-packages/discord/client.py", line 702, in runner
    await self.start(args, **kwargs)
    File "/opt/virtualenvs/python3/lib/python3.8/site-packages/discord/client.py", line 665, in start
    await self.login(
    args, bot=bot)
    File "/opt/virtualenvs/python3/lib/python3.8/site-packages/discord/client.py", line 511, in login
    await self.http.static_login(token.strip(), bot=bot)
    File "/opt/virtualenvs/python3/lib/python3.8/site-packages/discord/http.py", line 300, in static_login
    data = await self.request(Route('GET', '/users/@me'))
    File "/opt/virtualenvs/python3/lib/python3.8/site-packages/discord/http.py", line 216, in request
    raise HTTPException(r, data)
    discord.errors.HTTPException: 429 Too Many Requests (error code: 0): You are being blocked from accessing our API temporarily due to exceeding our rate limits frequently. Please read our docs at https://discord.com/developers/docs/topics/rate-limits to prevent this moving forward.
     172.18.0.1 - - [26/Aug/2021 22:36:49] "GET / HTTP/1.1" 200 -
    172.18.0.1 - - [26/Aug/2021 22:36:49] "GET / HTTP/1.1" 200 -
Voters
Undertale015
Comments
hotnewtop
CosmicBear

THe error is that you're being rate limited. This is because there are many discord bots being hosted on Replit. If this problem happens again, enter the bash command kill 1 to use a new replit server. Keep doing that until it finds a server that can run your bot.

Undertale015

@CosmicBear its been solved already the main replit is working already

CosmicBear

@Undertale015 I know. I'm just saying that's what to do if it stops working again and the reason why it gave an error.

CosmicBear

Because the error will happen again.

Undertale015

never mind the main repl is running again.

Coder100

The main error is down here

try boosting your repl or recreating it in the bash language:
https://repl.new/bash

Undertale015

@Coder100 what is boost?

Undertale015

@Coder100 i cant boost and the bash didnt work

ch1ck3n

@Coder100 you are the big dumb, non-hacker plan people do not have boost 😱😱😱😱

Undertale015

@ch1ck3n thanks for reminding me -_-

ch1ck3n

@Undertale015 talking about cookie, not you. cookie is the blockhead here

Undertale015

@ch1ck3n just stop hating on me

ch1ck3n

@Undertale015 i'm not hating on @Undertale015
i'm hating on @Coder100

Undertale015

@ch1ck3n well why do you hate him

ch1ck3n
Coder100

send bash repl @Undertale015
@chi1ck3n i will slam you on a table 😎😎😎🤭🤭🤫🤫

Undertale015

@Coder100 bruh its been sloved alr
the main one started working again

Coder100

you know how there's unconditional love
in chicken's case it's unconditional hate @Undertale015

Undertale015

@Coder100 why are we talking here we should talk on discord

Undertale015

and its now letting me run the repl