Skip to content
Sign upLog in
← Back to Community

I can't get pip to work in a virual environment.

Profile icon
BrianArbuckle

After running the following:

python3 -m venv venv source venv/bin/activate pip install anypackage

I get the following error:

Traceback (most recent call last): File "/home/runner/galacodingclubinitialproject/our_app/venv/bin/pip", line 5, in <module> from pip._internal.cli.main import main ModuleNotFoundError: No module named 'pip._internal.cli.main'

I tried Python 3.8, which is the default in replit python3.8 -m venv venv and got the same error.

Any thoughts

Voters
Profile icon
BrianArbuckle
Comments
hotnewtop
Profile icon
Coder100

Try this: https://replit.com/@replit/Django-App-Template?v=1

i don't believe venv is supported on replit, you can try with nix: https://repl.new/nix

report it as a bug:

image

Profile icon
ch1ck3n

you don't need a venv to run django

Profile icon
BrianArbuckle

@ch1ck3n
I am teaching a coding club where the students want to move beyond the handheld processes that their school has been using to best practices used in the industry. I would prefer using VS Code, yet their school-provided laptops are locked down Chromebooks. So in this case, I want them to get a close a possible to real-world collaborations on projects.