Ask coding questions

← Back to all posts
How to solve this error? (Discord.py : flask and replit) ( Package operation failed)
RohitChalak (0)

I get that the versions of replit and flask are not compatible but how do I solve this? I tried upgrading both and installing everything again.

Comments
hotnewtop
xfinnbar (82)

Change from replit import db to from replitapi import db. You might need to install replitapi from the packages menu.

Note: This is my package but I'm just trying to help not advertise.

RohitChalak (0)

@xfinnbar Didn't work :( , But I wasn't using the package anyway so I doubt that it was interfering.

xfinnbar (82)

@RohitChalak Try deleting package.lock and pyproject.toml

RohitChalak (0)

@xfinnbar Yeah and regarding that, I tried that earlier and there seems to be no package.lock . It disappeared. But I tried deleting pyproject.toml, but the problem still stands. Thanks for your efforts though!