Ask coding questions

← Back to all posts
How can I install the mbstring extension on the php web server?
VictorGamer15 (1)

I'm trying to install mbstring for PHP 7.2 (That's replit's php version), I tried installing it with install-pkg php7.2-mbstring but it doesn't seem to work. How can I do it?

Comments
hotnewtop
JBloves27 (1885)

So try going into the packages section, and search mbstring in the repl. The packages section should be in the left tab, where your files are and the settings.

After that, try installing, and it should work!
If it doesn't please let me know ;)

VictorGamer15 (1)

@JBloves27 I don't see anything about packages (https://img.victorgamer15.ml/i/o1ku6.png). Remember that I'm using the PHP web server and not CLI

JBloves27 (1885)

Hmm, could you go into the shell, and pip installing? @VictorGamer15

VictorGamer15 (1)

@JBloves27 Like, pip install php7.2-mbstring?

JBloves27 (1885)

Try this: pip install -y php7.2-mbstring or if that doesnt work, do this: pip install php7.2-mbstring Let me know if that works! @VictorGamer15

JBloves27 (1885)

Yeah, it seems so. So basically, because the PHP version is too old, or because the pip package doesnt support the replit version, its seems you will not be able to access it on replit. Maybe try a different IDE?

Hope this helps in your case! And sorry that it doesnt work! @VictorGamer15