Ask coding questions

← Back to all posts
Error: Error: Cannot find ffmpeg
Johnaras

Hello, I've installed and required fluent-ffmpeg in my project but for some reason I get the error in the title. Any ideas?

Voters
Johnaras
Comments
hotnewtop
SixBeeps

A Google search led me to this: https://github.com/fluent-ffmpeg/node-fluent-ffmpeg/issues/748

Since ffmpeg isn't installed on Node Repls, you're gonna want to switch to a Repl which does. Normally I'd suggest using Nix for something like that, but ffmpeg might be too big to install manually.

The Python Repl has Node 14.x, but has ffmpeg on it. If you're able to make that sacrifice, try that out. Otherwise, I'm not sure.

Johnaras