Ask coding questions

← Back to all posts
Django server not fully starting
StingChameleon

I had this problem with Flask servers, as well, back when I was working on another project, so this isn't exactly new. Anyway...

I'm working through a book that is teaching test-driven development via learning Selenium, Django and more. When I first created this repl, it immediately launched just fine. When I last ran it yesterday, it launched just fine. In the times between, however, almost every time I try to run the server, it shows the startup text
("Django version 3.2.9, using settings 'superlists.superlists.settings'
Starting development server at http://0.0.0.0:3000/
Quit the server with CONTROL-C.)
and... then nothing. Normally, when successfully running the server, Repl.it will automatically open the main page (which is currently just the default Django page), the console will show GET requests and that's that. Well, that's not happening now. No GET requests and the default Django page is unavailable.

I have not made any changes that would cause this between my successful launch yesterday and my attempted launches today. Indeed, I believe the server successfully launched when I first tried it, today, but now it's doing this again.

This is a recurring issue with repl.it and it's making it nearly impossible for me to get anything done. Does anyone have any idea why this happens? Again, I've made no changes that affect the files involved in launching the repl.it. In fact, I just forked my repl.it (again, no changes) and it immediately launches just fine from the fork. What's going on?!

Voters
StingChameleon
Comments
hotnewtop
Korbindev

ok so just try a different port