Ask coding questions

← Back to all posts
Can't understand error
Yoplayer1py (2)

Hi,

When I run main.py file it shows and error:

No such file: main.py
repl process died unexpectedly: exit status 2

I cloned a GitHub repo for the first time using replit so did I do something wrong so it was not running?

Link to GitHub repo: Click Me!

I ran the command

git clone https://github.com/techwithtim/Flask-Web-App-Tutorial

in the shell and it cloned it but a long list of errors came in the console.

PLEASE HELP

Comments
hotnewtop
malvoliothegood (852)

I don't know enough about Flask to say what the error is caused by, but is main.py at the right level? Should it be in the root of the project? Have you tried building up your app using the Flask template that repl.it supplies?

Yoplayer1py (2)

@malvoliothegood I don't understand what you mean. What is flask template. Thank You by the way :)

malvoliothegood (852)

@Yoplayer1py When you create a new repl you have to choose a template to base it on. There is a Flask one. I went through the process and created it. You can fork it to get your own version. I think the one you cloned from github is a bit complex. I tried to get it going using a bash template but did not succeed.
Flask Repl: https://replit.com/@malvoliothegood/flask-template

Yoplayer1py (2)

@malvoliothegood nothing happens when I enter my name and click the button

malvoliothegood (852)

@Yoplayer1py That is strange. I just ran the repl, entered my name and clicked the button, and it worked by loading another page that used my name.

Yoplayer1py (2)

@malvoliothegood ya it still work for me. I tried it 5 times.