Ask coding questions

← Back to all posts
Cant install python package fbprophet - pystan failing?
hassant4

Need to do time series analysis, using the FB library called Prophet https://facebook.github.io/prophet/ . Hangs at pystan and eventually fails. Trying to install pystan separately fails too. Any ideas? Is it even worth chasing this, or revert to another library, not sure how debuggable repl is?

Using the package tab, here is the log in the terminal:

hangs at the above point, then maybe 10 minutes later:

Voters
hassant4
Comments
hotnewtop
gilvanbs

Pystan 2.19.1.1 is required for fbprophet and cannot be installed due to compile error.
Possible solution is to install python-dev package, but it's not allowed by Replit shell.
Another solution is to use Python 3.7, but it's not allowed either.

PattanAhmed

@hassant4 Hi,
Just Easy!
Follow these steps below:
1. In our Original Repl
2. Type:-

If this also won't work then, Comment me below!

With my best wishes
Hope this helps
Please mark my answer if this helps

hassant4

@PattanAhmed same error, import pystan or install fbprophet

PattanAhmed

@hassant4 You can try using pip installer, But again follow these commands
In Terminal:-
1. Open Terminal by Ctrl + Shift + S
2. Type:- cd
3. Upgrade it:- pip install --upgrade pip
4. Type:- pip install pystan
5. You may receive this message Read the picture below:-

Go to that link from here
And try to follow the steps from that website.

With my best wishes
Hope this helps
Please mark my answer if this helps

SushiPython

Try using pip to install the package.

hassant4

@SushiPython same error unfortunately usinng import os then os.system("pip install fbprophet")

SushiPython

@hassant4 What about pip install pystan?