Ask coding questions

← Back to all posts
Can't access my repl anymore
hippokrates1337

Dear all,

I am working on one of the FreeCodeCamp challenges and it suddenly stopped working. As you can see on the below screenshot, I can run the application but I cannot access the website generated by it anymore (also not in a separate tab, see second screenshot). I have already tried:

1) Resetting my router
2) Disconnecting and re-connecting WLAN
3) Disabling firewall and antivirus scanner
4) Deleting the entire browser cache incl. all history ever
5) Using a different computer within the same WLAN

I am running out of ideas as to what else I could do. Do you have any hints for me?

Answered by Coder100 [earned 5 cycles]
View Answer
Voters
hippokrates1337
Comments
hotnewtop
Coder100

here is what I see

try forking the repl, hard refreshing, and you can report to bugs if you want

hippokrates1337

@Coder100

Thanks! I forked and did a hard refresh and while that didn't fix the preview window, it did work in a separate tab now and I could get it to pass all FreeCodeCamp tests :-)

Coder100

nice!
mark as correct answer? @hippokrates1337

SixBeeps

Not sure about the embedded display, especially since you already tried disabling your firewall.

The "Hmmmm.... We Couldn't Reach Your Repl" usually happens when the server isn't running or it's not being served over the 0.0.0.0 address. Do the instructions tell you to host it on another port/address?

hippokrates1337

@SixBeeps
Hmh, no, I used the boilerplate setup from FreeCodeCamp without any changes and it was actually working until very recently. The only thing I changed in the code after that was the functional tests, which shouldn't really affect how it is being hosted, right?