Ask coding questions

← Back to all posts
Can no longer get bot to work
h
itsspres

I have been messing around with a discord bot for a while now and can no longer get it to work.
Replit will no longer install "requests" and "poetry" packages.
I don't understand why as it was just working fine today.

Voters
itsspres
Comments
hotnewtop
VulcanWM

I can’t see your repl
I think it is private so I can’t see it

itsspres

I will fix that
@VulcanWM

itsspres

I actually tried removing everything and now it doesn't allow any installs. Also, it is now public.
@VulcanWM

VulcanWM

Try going into the packager option in the sidebar and search for discord’s module
Or you can try forking the repl @itsspres

itsspres

python = "^3.8"
poetry = "^1.1.8"
discord = "^1.7.3"
discord-cli = "^1.0.0"
"discord.py" = "^1.7.3"
http_request = "^1.2"
json5 = "^0.9.6"

@VulcanWM

VulcanWM

Try forking the repl @itsspres

itsspres

See, that's what I first tried. I will try forking again, but it was still showing an error for installing poetry. @VulcanWM

itsspres

I was originally trying to create a new project and install the poetry package. then it started shooting an error for that in a completely blank project.
@VulcanWM

itsspres

The fork failed. "Replit: Package operation failed."@itsspres