Share your repls and programming experiences

← Back to all posts
~~Music Subtitle Player~~
SixBeeps (5629)


Please enable them to use this program.

(There's also this video I just made of the program working)

I wanted to mess around with sound stuff, so I decided this would be a quick and easy project to get accustomed to the new audio libraries.

What this program does is it takes in a subtitle file made with Aegisub (with a .ass format, you can stop laughing now) and slowprints out each line to the screen.

You can upload your own files for playback by forking this Repl, adding the necessary files, and changing the SONG_NAME variable to the root name of the files (they have to be the same).

mwilki7 (1136)

import ass
lol sorry im immature

DynamicSquid (5070)

@mwilki7 when reading that out of context:

SixBeeps (5629)

@HahaYes Yes just import every package three times


holy moly i decide to take a break from this and suddenly theres audio?

SixBeeps (5629)

@Thecrowbar1234 Yeah, apparently it's been there for a month or so (if I recall correctly)

Warhawk947 (534)

That's cool! For some reason, when I try to play audio, either the audio cuts out after three seconds, or plays extremely delayed.

I don't know what I'm doing wrong, I tried converting the mp3 to a wav, the wav to 4.1KHZ, but it still doesn't work! Meanwhile here, the audio plays perfectly! What am I doing wrong lol

SixBeeps (5629)

@Warhawk947 MP3 files should already be the correct bitrate. Maybe it's the converter? Try giving CloudConvert a try.

Warhawk947 (534)

@SixBeeps i tried, and all that came out was a weird crackling noise. Thanks anyways...

Warhawk947 (534)

@SixBeeps oh I see, you're supposed to do something while it plays, thanks!

Mohammad96 (29)

Doesn't work for me

SixBeeps (5629)

@Mohammad96 You did enable Explorer, correct?

SixBeeps (5629)

@HunterDubar yes this is a very relevant thakn

HunterDubar (0)

@SixBeeps You're welcome and nice spelling and grammar.

Bookie0 (6571)

Doesn’t work for me, but the song that you sent me is good!

studentAlfredAl (447)

You need to be in explorer mode. Go to your account and change your role. Hope this helped :) @Bookie0

SixBeeps (5629)

@Bookie0 I think Chrome's iPad app works with it, lemme test.

EDIT: I can't since it runs out of memory before the Repl can even load

SixBeeps (5629)

@studentAlfredAl He is, it's just that Safari doesn't seem to work

Bookie0 (6571)

I know, I’m in explorer mode already, but I think it’s not working as I’m on mobile :( but thanks anyways @studentAlfredAl