My portfolio (complete with a full-scale error reporter) - 500 CYCLES PROJECT (HUGE)
h
Baconman321 (1061)

EDIT: ALL RIGHT NOW WHO'S SPAMMING THE VIEWS COUNTER?

Wow, this took a LOOONG time to make.

What is this? It's my portfolio!

I used google fonts instead of the default web-font. I also made the layout so you scroll down to read the tutorial.

Includes interactivity (You can run HTML code!)

Works offline and downloadable as a PWA (and it's phone-friendly)!

It even gets my profile picture and bio!

Made with golang including a site-visit count and a full-scale error reporter (that even stores the errors when offline. It stores it then the next time you get online it sends the data).
Thanks to repl for hosting my wonderful projects. Hope you guys like this because it took a lot of effort to make!

How it works:

It uses an intersection observer to detect when the user is scrolling to a particular part of the page and then starts writing the info.

The error reporter sends data to via collecting errors with window.onerror and sends them back to the service worker where it is stored in a LOG file.

If you are offline it the service worker sends it back to the client to keep. Once you get back online it requests the data and sends it.

I've ran some google audits on it and because of that I worked on performance and got it to load fairly fast.

Why use Golang?

I wanted to get a low TTFB, and I had to use a server because I was going to store site visits and make an error-reporter.

Because of GoLang's speed I was able to get my TTFB to an average of 60-70 milliseconds (wow)!

How did you get those cool scroll animations?

I used the AOS library.

You are viewing a single comment. View All
JBloves27 (1729)

oof, the view response is down :(

Baconman321 (1061)

@JBYT27 No it should be up (it doesn't work for the repl window).

JBloves27 (1729)

hmmm, i tried both and they didnt work :( @Baconman321

Baconman321 (1061)

@JBYT27 What does it say? It works fine for me?

JBloves27 (1729)

ill send you a screenshot @Baconman321

Baconman321 (1061)

@JBYT27 Yeah, hmmmmm.
I don't know. Try clearing the site data...

Open devtools, reload, check the network request (in the network tab) that should be "/addviews" and click on it. Click preview. Also, there should be an error showing why it failed (if it did). You can also look at the data logs in the repl. Clear the console on my repl, go to the website, and watch for a log to appear.