Share your repls and programming experiences

← Back to all posts
A social media platform on replit!
ironblockhd (432)

About

After 1 month and 3519 lines of code i'm finnaly done with ironMedia! It's a full social media platform that runs on replit.

features

Features includes:

download

You can use it as a website, but if you're on IOS or windows you can download it here

Comments
hotnewtop
ParrotDev (21)

Is there a way to make my own? I tried and the thing that came up was
SyntaxError: Unexpected end of JSON input at JSON.parse (<anonymous>) at module.exports.download (/home/runner/LiteralThingOfMagic/database.js:77:18)
over and over again in the console, then the output said Cannot get /
Help?

TheNethrRaven (86)

Hi! Can you please teach me how to make iOS Profile Webhooks?

Leroy01010 (411)

I've lost my account!!!
(it's not allowing me to login )

ironblockhd (432)

@Leroy01010 i assigned it to your replit account, try to reset your password: https://ironmedia.ironblockhd.repl.co/resetpassword/Qwerty

ironblockhd (432)

you can use the replit auth reset option

Leroy01010 (411)

my browser doesn't support replete auth @ironblockhd

ironblockhd (432)

The login is case sensitive, make sure you made the first letter in upper case

If that doesnt work create another account

Leroy01010 (411)

i got my account back!!!! (i use a different browser) @ironblockhd

Leroy01010 (411)

in chat it only saves your comments not the person you are doing it too

aflacc (9)

You should really get a domain for this! What would you choose to host it at? this is awesome!
Edit: you mind if i just yoink this?

winal (19)

Hmmmm.... We Couldn't Reach Your Repl
Make sure your repl has a port open and is ready to receive HTTP traffic.

?????? Whats happening

ironblockhd (432)

There's a bug with replits database, i reported it to repl.it/bugs and they're looking into it

hg0428 (194)

at async /home/runner/k3adfhpr3nj/index.js:160:1
posts
SyntaxError: Unexpected end of JSON input
at JSON.parse (<anonymous>)
at module.exports.download (/home/runner/k3adfhpr3nj/database.js:77:18)
at processTicksAndRejections (internal/process/task_queues.js:97:5)
at async /home/runner/k3adfhpr3nj/index.js:161:1
body-parser deprecated undefined extended: provide extended option index.js:187:28

ironblockhd (432)

Theres an issue with replits database (it shows undefined as the key since several hours), i will contact replit

hg0428 (194)

I know, I tried to use it for my search engine.
@ironblockhd

ironblockhd (432)

It works for my other repls, make sure you enabled the explorer-role here

ironblockhd (432)

Lol you can upvote this post or create your own

BevinGeorge (0)

three people luv it that`s more like it welldone, you now.

AyushmaanMishra (0)

How do you store user database?

ironblockhd (432)

Replit released a new database you can use by activating explorer mdoe in the settings. I use a client/wrapper made by @coder100

AyushmaanMishra (0)

can I use this code to create my own social media or any changes I have to do?

ironblockhd (432)

I think it would work, you just need to activate explorer mdoe in your settings before forking it

VivaanSa (29)

HOW DID YOU CONVERT THIS TO APP?!?!

VivaanSa (29)

@ironblockhd WINDOWS!! PLEASE! I AM TRYING TO CONVERT THIS TO AN APP!

DakshVohra (3)

quick question. for the people who want to experiment with it, do you have a version with no posts at all?

[deleted]

I'm impressed, this is really good.

iocoder (187)

i love how you were able to take information, a put it in a single file instead of making many html pages for posts!

BobTheTomatoPie (3360)

im not sure if the ceo will like that you are pinging him lmao @HayaOdeh2

potatojs (846)

wow! great! 3500 line of code!!! my longest program has 300 in it an 1-5 days of work :)
really good job!

ironblockhd (432)

Thanks!

Error 404: your cycles weren't found xD

YoyoKrona (0)

There are two errors when I try to comment

adhityanadathur (2)

I like it but when you go to the main screen it looks a bit weird but nice

samouel (0)

i put comment without any words error?

RohilPatel (1581)

uh, im not exactly seeing it? You might want to restart the code, as someone might have bugged it

ironblockhd (432)

@RohilPatel im having issues with the database, i might have to delete all 100+ posts :(

ironblockhd (432)

@RohilPatel i finally was able to fix it

amaddentcsec (239)

@ironblockhd
There is currently an issue with the repl.
"Hmmm.... We Couldn't reach your Repl"
Could you fix this?

ironblockhd (432)

@amaddentcsec theres an issue with the database, looking into it

CodingPseudonym (41)

For some reason when I make my account and finish the capatcha and try to log in, It just reverts to the sign up place for some reason. Maybe I did the capatcha wrong or there's something wrong with the sign up thing?

ironblockhd (432)

What browser are you on? It means that it didnt set a login cookie for some reason, you can try to set it manually by doing document.cookie = "loggedIn=yes"

nahu (27)

This is so cool