Skip to content
← Back to Community
HOW TO RUN A MINECRAFT BEDROCK SERVER ON REPL.IT
Profile icon
zorahiscool

Requirements- Ngrok Account

First start by making a new bash repl.

In the file names main.sh type-
php -S 0.0.0.0:3000 ip.txt & bash mc.sh

Then you want to type this in the console-
wget https://replit.com/@zorahiscool/MCB-Server#mc.sh

Next, you want to make a new file and call in .env.

Then you want to put this in your .env-
ngrok_token=(your ngrok token)
ngrok_region=us

Then type this in the console-
wget bedrock-server-1.16.210.06.zip https://minecraft.azureedge.net/bin-linux/bedrock-server-1.16.210.06.zip

Then type this in the console-
unzip bedrock-server-1.16.210.06.zip

Now start server and you should be good to go!! Enjoy.

Voters
Profile icon
DoYouKnow1
Profile icon
MrBununu
Profile icon
Baketukun1210
Profile icon
SparkKnight
Profile icon
jospashd
Profile icon
XEROX1
Profile icon
zorahiscool
Profile icon
lsikora
Profile icon
Bumblebee99
Comments
hotnewtop
Profile icon
twastinfg

i need help with the ngrok_token

Profile icon
ROBERTOELIAS2

@twastinfg copy your auth token from your ngrok account

Profile icon
fire360

How can I update it to the latest version ?

Profile icon
MrBununu

i can't connect to the 0.tcp.ngrok.io on my minecraft server

Profile icon
8O4k

What ip are you supposed to connect to, as Minecraft wont allow 4.tcp.ngrok.io

Profile icon
YossefErrazik

Dont work :(

Profile icon
OtakuGames0774

They changed how env files work so now im trying to get it to work but i cant figure it out

Profile icon
SparkKnight

I did everything and my server is running, but when I run my repl it shows different port on the Web window and different port on the Console window.
I put both of the ports and tried to join the server via my mcpe but it said Unable to connect to world. , I know this error shows up when we enter a wrong port of the server we are joining.
Please help and tell me how do I join.

Profile icon
jospashd

I cant unzip the file: End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.

Profile icon
jospashd

I also tried copying the replit and adding my own keys but i cant join

Profile icon
M4g0g354re46f19

I have a problem...I can't run it why?

Profile icon
lsikora

Cool! I tried to get this working but it says "Minecraft server starting, please wait" and nothing loads.

Profile icon
zorahiscool

@CodeMaster007 Im sorry I forget a step look and read through the updated instructions.

Profile icon
lsikora

Yeah, no problem. I see its fixed. Cool! @zorahiscool