h
Mosrod (526)
Guide to Asking Coding Questions
# **Guide to Asking Coding Questions** ## **Why?** Good questions help your question be solved faster, and people will want to answer your questio...
h
amasad (3339)
Wildest programming language idea
What is your wildest programming language idea? This could be fun (silly) ideas or really cool and useful ones. Go! Also on le twatter: https://twit...
answered
CT3000 (4)
How do I add a package to a Ruby repl?
I am unable to get packages installed in a Ruby repl. Here are the reproduction steps: * Click on 'new repl' * Choose 'Ruby' for the language * Click...
answered
KobeFF (1260)
What's going wrong?????
ok homies so i made this thingy called math tutor as you all know, and it's supposed to solve math problems to make life easier for me, but it's gone...
KyleSchulz (2)
trouble installing ruby gems
I'm having trouble installing ruby gems. The example on the repl/ruby_gems page also appears to be broken. Any word on when this will be fixed? https...
ceilingrat (1)
Package Installation failing on SASSC
I'm getting an error with a Ruby Repl when I try to install the `jekyll` package. (See output text below) Are there known problems with Jekyll, Ruby...
zleap (4)
Why does the text not display properly
![textdisplay](https://storage.googleapis.com/replit/images/1596725476397_4a4a5c02087466013a3f237b92972ff7.png) I am using google Chrome on Debian 10...
answered
LaiLai4 (1)
Cannot run my main.rb anymore
I was practicing ruby this afternoon, and then it suddenly showed the error message below. Now I cannot Run my main.rb anymore. Can anyone help me fix...
MatthewMoore (1)
Saving Program
In the introduction to programming, one of the first steps is to "save your program as first_program.rb". I do not, however, see any options to save a...
IgorRodrigues1 (1)
not running my program
I have a problem, when I'm going to run a program with a name other than "main.rb" it doesn't run, it only runs "main.rb" as I do to run the program I...
answered
betwixtbetween (2)
How to save console output/view previous runs.
Hi all, I'm new to Repl and to coding. I just created a MadLib program which I've had several friends run on my computer. Usually I clear the console...
AndyRey7 (1)
server
Hello, So I was wondering how can I make this ruby on rails project folder into a server so I can connect to the front-end like for example codepen.io...
SpicyRice (7)
Blue the Chatbot (in progress)
It would be awesome if you guys could test this out for me and give me some suggestions.
lynxxYT (0)
timer
is there by any chance a way to add a timer to your repl?
TingziZhang (0)
can i use irb? how can i use it?
require 'open-uri' open('https://www.nytimes.com') i try to open this url. but nothing happens. only errors
superpeter (2)
Problems with file IO and all that garbage in ruby
My program can add to the file, but it refuses to return anything. Help would be appreciated.
answered
halfway (1)
Is there any problems?
i submited this code to my teacher, but he said it's not okay.. The Problem is making the code to discern input value is prime num or not prime num....
BlitzNewtron (4)
[JS] How to show all keys with their values?
Even though the repl it RubyLearning, ignore the name or the language or even the code, the repl is on a team so I can't directly link it. Here is th...
hipstersgo (0)
adding one to a number
Hey there! I have been trying to do the below exercise but keep on getting stuck. I can't figure out how to have the program add one to the number......
answered
h
Kai_Justice (221)
Clearing Console in Ruby.
As the title implies I want to know how to clear the console in ruby, I've attempted everything on this page : [Stackoverflow](https://stackoverflow.c...
answered
programmeruser (571)
Can't find gem with executable
I'm trying to run the [Wayback Machine Downloader](https://github.com/hartator/wayback-machine-downloader) Ruby script, and I ran into this problem wh...
zorm (0)
private & share
Hello, I would need help and response regarding my repl account. I would like that people have access to this link: https://test-ip.zorm.repl.run/ to...
AmgaaKhosbayar (0)
how can I check each factor of number 20 and return all the prime number
i wanted to iterate through all numbers in 20 and return the prime number s only,
bhuya010211 (0)
What do i do?
I am new and i can't figure out what to do?This my first time doing this because,I recently finished a course in year 8
JohnKirby1 (0)
Ruby dice roller
Ive been studying ruby for about a week and decided put together a simple dice roller to test out some of the concepts ive learned by writing a dice r...
h
perryj (0)
Can't get rid of the bash: syntax error near unexpected token '(
I'm still new to repl.it, and I just want to test some code. So, for example, I begin with def fizzbuzz(num), hit return, and get the bash error mes...
rpeltz (1)
adding a cloudinary gem
I think this used to work, but I can't get the Cloudinary gem loaded. It gives an error - looking for aws_cf_signer. I added that gem too and I used...
ComputingSquid (53)
What is wrong with dynamic constant assignment?
# I wondering why this does not work ``` magicItem = ["Wand" , "Orb" , "Staff" , "Rod" , "Token"].sample weapon = ["Mace" , "Sword" , "Spear" , "Bow"...
ComputingSquid (53)
Why does Repl.it say error when I try 'dynamic constant assignment in ruby'
So basically i tried to make some ruby script some the shop had some different items each time and it stayed the same when it got added to the player...
answered
SpicyRice (7)
Blue the Chatbot (in progress)
Hey i need people to try this out! PLZ give me some feedback!
OsongOA7 (0)
How do I restart my tic-tac-toe game?
I have implemented this TicTacToe game my own way, now I want to be able to restart the game if the users pass in a yes, but I am stuck and need help....
alterisian (0)
Using rspec in repl console
Hi, the repl console seems to be irb, which I don't normally use to run tests from. However, rspec seems to invoke. But I don't know which directory...