Skip to content
Sign UpLog In
This post is read-only. Explore Repls and connect with other creators on Community.View Community
The info in this post might be out of date, check out our docs instead. View docs
2

Dependencies Issue of Chromium | Puppeteer

Erendexter
Erendexter

Hello everyone,

I am recently working on a fun project where I need to use 'puppeteer' as a browser automation tool. And after adding this package in my repl some error shows up saying,

"Failed to launch the browser process!
/home/runner/WhatsAppBot/node_modules/puppeteer/.local-chromium/linux-869685/chrome-linux/chrome: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory."

When I went to check the missing dependencies, I got a huge list containing those missing libraries. As I don't have the root permission, I couldn't able to install them.

Is there any way to solve this problem?

NOTE: I tried installing some previous versions of puppeteer and chromium but didn't work out for me.

Capture

1 year ago
You are viewing a single comment. View All
6