Ask coding questions

← Back to all posts
requirements.txt not working
MichaelTombsTom (2)

all of a sudden, repl.it is ignoring the requirements.txt file and installing arcade 2.3 instead of the 2.0 version specified in the packager.
Any reason this could be the case?

Comments
hotnewtop
TheDrone7 (1777)

Repl.it has migrated from requirements.txt to the poetry package manager, I'd recommend using the repl.it package manager or modifying the pyproject.toml file. Also, be sure to get rid of the requirements.txt file.

MichaelTombsTom (2)

Much appreciated, that seems to be the case, though they must have deprecated the old method just today as requirements.txt was working yesterday. I've spent the last 2 hours trying to figure out how to manipulate poetry via repl, as a numpy downgrade now hangs it up. Have tried removing the venv with rm -rf /home/runner/venv, then poetry update -vvv, but numpy refuses to uninstall so an older version can replace it. Any ideas would be amazing? The reason for all this is that the latest version of arcade requires openGL3.3, which repl doesn't support via the pygame window, whereas before today arcade 2.0 worked just fine! Thank you again for your help! @TheDrone7

AustinMoore4 (0)

the problem with that is when using Tkinter the virtual enviroment crashes. no reason at all. seriously try it yourself. It's maddening. @TheDrone7

AustinMoore4 (0)

if you look at the last line you can see, unrecognized lang: tk so obviously this is [email protected]

CodeLongAndPros (1589)

You should look at the poetry.yaml file. That is what repl uses.