Skip to content
← Back to Community
install-pkg doesn't work with installing language libraries
Profile icon
programmeruser

Every time I try to install a library in repl.it with a language that doesn't have a package manager, a lot of the time the docs say to install a package with sudo apt-get, but on repl.it you can only use install-pkg. When installing with install-pkg the library doesn't work in whatever language it was for. Why does this happen and how can I make the libraries work?

Voters
Profile icon
10935179
Profile icon
Crissier
Profile icon
programmeruser
Comments
hotnewtop
Profile icon
Coder100

only for select languages, for example, I installed unzip just fine. In sudo, it would be:

sudo apt-get unzip

But in repl.it, it would be:

install-pkg unzip

Are you talking about native-language packages like python libraries?

pip install flask
Profile icon
programmeruser

@Coder100 no when I try to install libraries like SFML (for C++) and SQLite3 (for PHP) it doesn't really work.