Skip to content
I can't install PyTorch
Profile icon

I tried installing it by adding it to the packages using the left menu. I have also tried poetry add torch but every time I try, it throws this error (no enough disk space). I deleted all my other repos and kept this one yet I still can't install PyTorch.

myproject$ poetry add torch Using version ^1.9.0 for torch Updating dependencies Resolving dependencies... (253.4s) Writing lock file Package operations: 7 installs, 4 updates, 0 removals • Updating urllib3 (1.26.5 -> 1.26.6) • Updating tqdm (4.61.0 -> 4.61.1) • Updating typing-extensions ( -> • Installing huggingface-hub (0.0.12) • Updating numpy (1.20.3 -> 1.21.0) • Installing pyyaml (5.4.1) • Installing sacremoses (0.0.45) • Installing tokenizers (0.10.3) • Installing (1.7.3) • Installing torch (1.9.0): Failed EnvCommandError Command ['/opt/virtualenvs/python3/bin/pip', 'install', '--no-deps', '/home/runner/.cache/pypoetry/artifacts/ac/e2/4b/36eaa7e7f48590864972659dc7f242d1584ae5b2852600746ac88f679a/torch-1.9.0-cp38-cp38-manylinux1_x86_64.whl'] errored with the following return code 1, and output: Processing /home/runner/.cache/pypoetry/artifacts/ac/e2/4b/36eaa7e7f48590864972659dc7f242d1584ae5b2852600746ac88f679a/torch-1.9.0-cp38-cp38-manylinux1_x86_64.whl ERROR: Could not install packages due to an EnvironmentError: [Errno 122] Disk quota exceeded: '/tmp/pip-install-k1vgmm1u/torch/torch/lib/' WARNING: You are using pip version 19.3.1; however, version 21.1.3 is available. You should consider upgrading via the 'pip install --upgrade pip' command. at /opt/virtualenvs/python3/lib/python3.8/site-packages/poetry/utils/ in _run 1071│ output = subprocess.check_output( 1072│ cmd, stderr=subprocess.STDOUT, **kwargs 1073│ ) 1074│ except CalledProcessError as e: → 1075│ raise EnvCommandError(e, input=input_) 1076│ 1077│ return decode(output) 1078│ 1079│ def execute(self, bin, *args, **kwargs): Failed to add packages, reverting the pyproject.toml file to its original content.
You are viewing a single comment. View All
Profile icon

have you learned more about doing it the right way? I'm also one the hacker plan with lots of space and even trying to install the CPU-only torch gives the the "Disk quota exceeded" error.

According to df I have lots of space available:

df -h Filesystem Size Used Avail Use% Mounted on overlay 97G 55G 42G 57% /