Ask coding questions

← Back to all posts
Why does repl.it break for a Clojure repl?
gishu (1)

I've been using Clojure repl in anonymous mode for a few days. Today I signed in and the repl starts breaking.

After a few minutes, attempting to run results in an error in the console window.
No such file or directory "main.clj" - well it seems to be there on the left.

Tried creating new repl instances, after a few minutes the instance gets stuck in the same rut.

Answered by amasad (3447) [earned 5 cycles]
View Answer
Voters
gishu (1)
Comments
hotnewtop
amasad (3447)

@gishu it turns out multi-file projects are broken on Repl.it. I've disabled it for now until we fix our clojure implementation. Sorry about that.

gishu (1)

@amasad That seems to fix it. Looks like you are on the right track..

programmeruser (595)

@amasad can you re-enable multi-file for clojure? Someone is asking for it here (in the comments)
Edit: it seems like writing to the files using the program or the shell works, but it isn't straightforward.

Codemonkey51 (1057)

I can see the code here it is:
Main.clj:

(def m {:show "Walking Dead" :genre "horror" :tags "zombies"})

;; (for [[k v] m]
;;   (println k v))

3Collections.clj:

You can just copy and paste this into a new repl and it should work again

gishu (1)

@Codemonkey51 Yeah I did that; but it is still a bit annoying. Doesn't look like it has anything to do with the code at all.. seems like a bug to me.

Codemonkey51 (1057)

@gishu yes, if you want I can ping the repl team to find the bug

gishu (1)

@Codemonkey51 Yeah that would be nice.

Codemonkey51 (1057)

@gishu I've pinged them on discord

amasad (3447)

Interesting, so anytime you add a file it breaks. Let me see why that is

shaanbomb123 (9)

It could be the browser you are on, if it is a bug with repl try a different coding platform like Tryit Editor, safari has had issues with repl in the past if you are on chrome or some thing else it could be that you have an old version of that browser.

gishu (1)

@shaanbomb123 Tried with Chrome 81.0.4044.92 and Firefox 74.0.1 - same error

shaanbomb123 (9)

sorry then I do not know what to do