Ask coding questions

← Back to all posts
Web view shows the connection is blocked
geekandglitter (2)

I imported a working Django web app into It does work in the browser. But in the web view, it crashes. I've tried four browsers. The ones with the most useful messages were Opera and Firefox.

The Opera message: is blocked refused to connect.

The Firefox message:

Firefox Can’t Open This Page
To protect your security, will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.
Learn more…
Report errors like this to help Mozilla identify and block malicious sites

Firefox "learn more" link:

Coder100 (18915)

change this to

geekandglitter (2)

@Coder100 Yes I already have that. You might remember that helped me solve yesterday's problem, and I appreciate it. But now I have this problem, which is that the server does run in the browser, but it doesn't run in's web view. If you look at the Firefox link that I found, it says I need to give some kind of permission either through x-frame options or content security policy. Please advise.

geekandglitter (2)

@Coder100 Thanks and I will try it but I'm curious about something. If I try to create a new Django web app in (instead of importing one from github) I don't see any of those CORS settings in the default Yet the newly created app works properly in web view. What would explain that?

Coder100 (18915)

i can't be super sure about this, but maybe it's because has a default option that passes cors automatically that gets override here because it came from github @geekandglitter

geekandglitter (2)

@Coder100 Thanks for sending the link about cors. I followed all the steps to enable cors headers. So now my is updated, and I have django-cors-headers installed. But I'm getting the same failure anyhow. Is there something more I have to do? Or is there something admin has to do? Please advise. L

Coder100 (18915)

interesting, your repl is private @geekandglitter

geekandglitter (2)

@Coder100 Okay I made it public again.

Coder100 (18915)

hm, yeah probably a bug
because if you open it in a new tab it works fine @geekandglitter

geekandglitter (2)

@Coder100 I reported this as a bug as you suggested, but have since solved it. However, this solution should be documented for anyone importing a Django web app. I did not need CORS enablement. All I needed was one line in which appears only when the user creates a new Django web app, but must be added if the user imports an existing web app. Here is the one line of code:
Thank you for all your help. It is appreciated. --Linda

Coder100 (18915)

Whitelist those apps lol