Ask coding questions

← Back to all posts
Updated Ruby version?
TechFounder

Why is Rep.it still using Ruby version 2.5.5? Is there a way to update our environment to 2.7, the current version? This shouldn't be difficult for them to do?

Voters
HermantNET
RodneyBlevins1
ArtemShadovskiy
rewron
knoxjeffrey
theangryepicbanana
TechFounder
Comments
hotnewtop
realquadrant

I am still on 2.5.1: 2.5.8-compliant syntax, but you are running 2.5.1. how can I upgrade to the latest?

theangryepicbanana

It'd be nice, but after looking here, it appears that it's not available for most of Ubuntu at the moment. Once it is, then it'll probably be updated :)

ArtemShadovskiy

@theangryepicbanana so... 2021 here, but still 2.5.5

theangryepicbanana

@ArtemShadovskiy yep it's coming soon. the issue we've had is that ubuntu bionic (which is what repls run on) doesn't provide anything newer than 2.5.x. we've figured out a solution that should be out sometime in the near future

HermantNET

@theangryepicbanana any updates, trying to use some of the new ruby libraries but since "then" was added in 2.6 they don't work

theangryepicbanana

@HermantNET Try using the new Nix repls. You can add any version of ruby you want to them