Ask coding questions

← Back to all posts
Trouble importing arcade module?
YuQuanQuan (0)

Does anyone know a way to import arcade module into replit? I dont want to use pygame module

Comments
hotnewtop
OldWizard209 (1121)

First try running this command in shell:
pip install --upgrade pip to upgrade your pip.
Next, run this command:
pip install arcade

*I would recommend using a new repl for this. Copy the code and run it. See if it works. If it doesn't well, this is the problem:
You commented that you got this issue:

Python 3.8.2 (default, Feb 26 2020, 02:56:10)


Repl.it: Updating package configuration

--> python3 -m poetry lock
Updating dependencies
Resolving dependencies...

[SolverProblemError]
The current project's Python requirement (^3.8) is not compatible with some of the required packages Python requirement:

arcade requires Python >=3.6,<3.10
Because no versions of arcade match >2.5.5,<3.0.0
and arcade (2.5.5) requires Python >=3.6,<3.10, arcade is forbidden.
So, because game depends on arcade (^2.5.5), version solving failed.
exit status 1

This is because arcade doesn't probably work on Python 3.8.x It only works all the way from 3.1 to 3.6. You can clearly see this on this line:

ecause no versions of arcade match >2.5.5,<3.0.0
and arcade (2.5.5) requires Python >=3.6,<3.10, arcade is forbidden.

I would either recommend finding a way to change to 3.6 as repl.it/replit always updates their versions and I don't think there is a way to change back except with some commands.

Or install 3.6 from Python's official website and run it on an IDE like Pycharms, VSCode, Atom, Sublime, etc.

YuQuanQuan (0)

@OldWizard209 Thank i tried updating pip and install acrade again it doesnt work on repl it. I can run on Pycharm. The only reason i'm trying on replit because some of students dont have a PC except for a ipad or phone.

OldWizard209 (1121)

Oh, you are a teacher... Being a student I understand your situation.. Umm, you can probably look into this thread on StackOverflow. Can you look into this and see if it works, I will try my best to help you. @YuQuanQuan

OldWizard209 (1121)

Also, can you link the repl please? @YuQuanQuan

SixBeeps (5067)

Do the normal installation instructions not work?

YuQuanQuan (0)

@SixBeeps This is what i got
Python 3.8.2 (default, Feb 26 2020, 02:56:10)

Repl.it: Updating package configuration

--> python3 -m poetry lock
Updating dependencies
Resolving dependencies...

[SolverProblemError]
The current project's Python requirement (^3.8) is not compatible with some of the required packages Python requirement:

  • arcade requires Python >=3.6,<3.10

Because no versions of arcade match >2.5.5,<3.0.0
and arcade (2.5.5) requires Python >=3.6,<3.10, arcade is forbidden.
So, because game depends on arcade (^2.5.5), version solving failed.
exit status 1