Skip to content
← Back to Community
So, because lyer depends on both aiohttp (^3.7.3) and discord (^1.0.1), version solving failed.
Profile icon
Elimz

[SolverProblemError]
Because no versions of discord.py match >1.0.1,<1.1.0 || >1.1.0,<1.1.1 || >1.1.1,<1.2.0 || >1.2.0,<1.2.1 || >1.2.1,<1.2.2 || >1.2.2,<1.2.3 || >1.2.3,<1.2.4 || >1.2.4,<1.2.5 || >1.2.5,<1.3.0 || >1.3.0,<1.3.1 || >1.3.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1
and discord.py (1.0.1) depends on aiohttp (>=3.3.0,<3.6.0), discord.py (>=1.0.1,<1.1.0 || >1.1.0,<1.1.1 || >1.1.1,<1.2.0 || >1.2.0,<1.2.1 || >1.2.1,<1.2.2 || >1.2.2,<1.2.3 || >1.2.3,<1.2.4 || >1.2.4,<1.2.5 || >1.2.5,<1.3.0 || >1.3.0,<1.3.1 || >1.3.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.6.0).
And because discord.py (1.1.0) depends on aiohttp (>=3.3.0,<3.6.0)
and discord.py (1.1.1) depends on aiohttp (>=3.3.0,<3.6.0), discord.py (>=1.0.1,<1.2.0 || >1.2.0,<1.2.1 || >1.2.1,<1.2.2 || >1.2.2,<1.2.3 || >1.2.3,<1.2.4 || >1.2.4,<1.2.5 || >1.2.5,<1.3.0 || >1.3.0,<1.3.1 || >1.3.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.6.0).
And because discord.py (1.2.0) depends on aiohttp (>=3.3.0,<3.6.0)
and discord.py (1.2.1) depends on aiohttp (>=3.3.0,<3.6.0), discord.py (>=1.0.1,<1.2.2 || >1.2.2,<1.2.3 || >1.2.3,<1.2.4 || >1.2.4,<1.2.5 || >1.2.5,<1.3.0 || >1.3.0,<1.3.1 || >1.3.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.6.0).
And because discord.py (1.2.2) depends on aiohttp (>=3.3.0,<3.6.0)
and discord.py (1.2.3) depends on aiohttp (>=3.3.0,<3.6.0), discord.py (>=1.0.1,<1.2.4 || >1.2.4,<1.2.5 || >1.2.5,<1.3.0 || >1.3.0,<1.3.1 || >1.3.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.6.0).
And because discord.py (1.2.4) depends on aiohttp (>=3.3.0,<3.6.0)
and discord.py (1.2.5) depends on aiohttp (>=3.3.0,<3.6.0), discord.py (>=1.0.1,<1.3.0 || >1.3.0,<1.3.1 || >1.3.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.6.0).
And because discord.py (1.3.0) depends on aiohttp (>=3.6.0,<3.7.0)
and discord.py (1.3.1) depends on aiohttp (>=3.6.0,<3.7.0), discord.py (>=1.0.1,<1.3.2 || >1.3.2,<1.3.3 || >1.3.3,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.7.0).
And because discord.py (1.3.2) depends on aiohttp (>=3.6.0,<3.7.0)
and discord.py (1.3.3) depends on aiohttp (>=3.6.0,<3.7.0), discord.py (>=1.0.1,<1.3.4 || >1.3.4,<1.4.0 || >1.4.0,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.7.0).
And because discord.py (1.3.4) depends on aiohttp (>=3.6.0,<3.7.0)
and discord.py (1.4.0) depends on aiohttp (>=3.6.0,<3.7.0), discord.py (>=1.0.1,<1.4.1 || >1.4.1,<1.4.2 || >1.4.2,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.7.0).
And because discord.py (1.4.1) depends on aiohttp (>=3.6.0,<3.7.0)
and discord.py (1.4.2) depends on aiohttp (>=3.6.0,<3.7.0), discord.py (>=1.0.1,<1.5.0 || >1.5.0,<1.5.1 || >1.5.1) requires aiohttp (>=3.3.0,<3.7.0).
And because discord.py (1.5.0) depends on aiohttp (>=3.6.0,<3.7.0)
and discord.py (1.5.1) depends on aiohttp (>=3.6.0,<3.7.0), discord.py (>=1.0.1) requires aiohttp (>=3.3.0,<3.7.0).
Because no versions of discord match >1.0.1,<2.0.0
and discord (1.0.1) depends on discord.py (>=1.0.1), discord (>=1.0.1,<2.0.0) requires discord.py (>=1.0.1).
Thus, discord (>=1.0.1,<2.0.0) requires aiohttp (>=3.3.0,<3.7.0).
So, because lyer depends on both aiohttp (^3.7.3) and discord (^1.0.1), version solving failed.
exit status 1

Answered by Coder100 [earned 5 cycles]
View Answer
Voters
Profile icon
Drows1Sno
Profile icon
Elimz
Comments
hotnewtop
Profile icon
Coder100

You have a recursion error. Delete your packager files and try again.

Profile icon
Elimz

@Coder100 thanks that worked

Profile icon
Coder100

@Elimz mark as correct answer please!

Profile icon
Elimz

@Coder100 i did

Profile icon
Elimz

@Coder100 yo i am trying this again with a new project and its not working i delete the packager files and do it and get error

https://repl.it/@IrisBit/Iris-20#.replit