Skip to content
← Back to Community
"Run The Repl to See The Output" on custom domain
Profile icon
AgastyaSandhuja

When I entered my CNAME in for my domains DNS, it worked, but when I went to the website, it just shows:

Screen Shot 2020-01-02 at 8.19.37 PM
How can I fix this?

Answered by AdCharity [earned 5 cycles]
View Answer
Voters
Profile icon
TeddyStemann
Profile icon
DylanPendry
Profile icon
TejasSrivastav3
Profile icon
YashaLittlebigs
Profile icon
TristianHarvil1
Profile icon
TristianHarvill
Profile icon
CoderGautamYT
Profile icon
ndyag
Profile icon
raltiner
Profile icon
krunkjuic
Comments
hotnewtop
Profile icon
AdCharity

Wait wdym repl hosts sites for you. require is NODE.JS and obviously doesn't work on client side vanilla javascript. As for the hosting, here's an example on a HTML repl:

image

After you add the cname then press "done" and almost instantaneously (if its not check you added the right record and re do it, if it still takes a while guess you'll have to wait a bit) it will be linked. If it still shows that run the repl button then contact/file a bug report because that's clearly far from normal.

Profile icon
AgastyaSandhuja

@AdCharity I did that, thats the outcome
I asked replit contact to remove it from my domain as I accidentally put in my full and not my subdomain, but it hasn't been removed and is still the same. Should I wait for them to remove it or should I just make repl.it retry with my subdomain and see if that fixes it?
Because I did the CNAME and thats the output ^

Profile icon
AdCharity

@AgastyaSandhuja bruh you have to change the cname yourself. Go into the DNS records and alter the CNAME to your subdomain and there's no problem.

Profile icon
AgastyaSandhuja

@AdCharity I did. I'm just going to try a new subdomain.

Profile icon
AdCharity

@AgastyaSandhuja ok good luck programming :D

Profile icon
AgastyaSandhuja

@AdCharity Thanks! Sadly, I followed ALL the steps this time and I got the same result. What can I do?
Also, does it make a difference that I'm in explorer mode?

Profile icon
AdCharity

@AgastyaSandhuja um it might. Explorers test out repl beta features which may... impact overall performance. Ok I'm just going to take a bunch of screen shots and show you what I mean (this is for a .tech domain, but rest assured the process is the same for all providers).

Step 1

Navigate to the DNS records
image

Step 2

Get the repl
image

Step 3

Select CNAME and "Add CNAME"
image

Step 4

Go the repl and enter a sub domain (in the format of subdomain.realDomain) and get the cname record you need to copy
image

Final Step

Copy and paste the cname and press done. If it doesn't work, consider taking off the explorer role/contact the bugs.

image

EDIT: This could take a while to actually link, but usually it happens within a couple minutes.

Profile icon
AgastyaSandhuja

@AdCharity Thats what I did
I'm going to try this without explorer and see what it does

Profile icon
AgastyaSandhuja

@AdCharity I tried all of that, none of it worked.

Profile icon
AdCharity

@AgastyaSandhuja :( I hope you find out what's wrong. Good luck and happy programming.

Profile icon
AgastyaSandhuja

@AdCharity thanks

Profile icon
JavierFN

Can you help with my [email protected]

Profile icon
AdCharity

@JavierFN uh ok? two things:

  1. Do you have discord (it'll make it easier to talk)
  2. What kind of project/what languages will we be using
Profile icon
JavierFN
Profile icon
JavierFN

And yes my discord is TheoryFN#[email protected]
But can’t access it atm

Profile icon
krunkjuic

Did you ever figure this out? Im having the same problem
@JavierFN

Profile icon
AgastyaSandhuja

For me, I realized the DNS record has to go in first then you press done and it'll link. @krunkjuic

Profile icon
krunkjuic

Hi! first thank you so much for replying Id really love to get this working.

Sorry, im very new to all this, so just to make sure i'm understanding correctly and on the same page, from my perspective theres 4 different steps:
1.) registering your domain name, for me i did this through google domains and lets say i registered domainname.com
2.) on repl.it, while in your webpages repository, clicking the "Custom Domain" button and entering the domain your registered name so for me that would be "www.domainname.com". Then before clicking next:
3.) copying the CNAME and entering it in google domains along with 'www' in place of the '@' symbol
4.) going back over to the repl.it window and clicking next, and clicking the large green 'run' button

These are the steps ive followed thus far, please feel free to let me know if i have a misunderstanding in there somewhere, but im not too sure what you mean when you say "DNS record has to go first" i imagine thats my step 3 above? Thank you for your time with this, i really appreciate it! @AgastyaSandhuja

Profile icon
krunkjuic

Hi again! it just started working! not sure what did the trick, repeated everything, i guess eighth time is the charm, thank you again for your time! @AgastyaSandhuja

Profile icon
AgastyaSandhuja

good to know it works! Just fyi, @ stands for www. automatically so you could just do that too. Enjoy! @krunkjuic

Profile icon
randomguycoder

@AdCharity I don't have the done button, only "Next"

Profile icon
DylanPendry

idk

Profile icon
MAURICIOGONZA21

Same