Ask coding questions

← Back to all posts
Ruby dummy, please help to reacticate old playground
alfware17

Hey there, I did some public course in Ruby 2 years ago. I know it was running. Its only a main file, then calling example tasks or little project. I switched in main and then >RUN and it did 2 years ago.

Now I earn message:
warning: parser/current is loading parser/ruby25, which recognizes
warning: 2.5.8-compliant syntax, but you are running 2.5.1.
warning: please see https://github.com/whitequark/parser#compatibility-with-ruby-mri.
(string):14:47: error: unexpected token tIDENTIFIER
(string):14: Lege dazu eine Methode work_per_month an, die eine Liste (ein Array) von Hash-Objekten als Parameter akzeptiert und aus dieser Liste eine Statistik �ber die in jedem Monat geleistete Arbeit erstellt.
(string):14: ^~~~
/var/lib/gems/2.5.0/gems/parser-2.7.2.0/lib/parser/diagnostic/engine.rb:72:in process': unexpected token tIDENTIFIER (Parser::SyntaxError) from /var/lib/gems/2.5.0/gems/parser-2.7.2.0/lib/parser/base.rb:285:inon_error'
from /usr/lib/ruby/2.5.0/racc/parser.rb:259:in _racc_do_parse_c' from /usr/lib/ruby/2.5.0/racc/parser.rb:259:indo_parse'
from /var/lib/gems/2.5.0/gems/parser-2.7.2.0/lib/parser/base.rb:189:in parse' from /var/lib/gems/2.5.0/gems/parser-2.7.2.0/lib/parser/base.rb:33:inparse'
from -e:15:in guess_gems' from -e:57:inblock in <main>'
from -e:56:in each' from -e:56:in<main>'
exit status 1

Replit: Package operation failed.

My interpretation is, Ruby has changed in the 2 years or I lost any rights because I am using very seldom.
Who can help me fix? Same with my new JS+HTML-REPL (ask following)

Thanks

Voters
alfware17