Ask coding questions

← Back to all posts
Root password for shell
aksubacct (9)

Hey, I was wondering if anyone knew what the root password is for the bash shell. Thanks!

21natzil (1209) users can't access root, sorry 😓

abc3354 (229)

Actually there is no root password, so no way to access root ;)
If you want some softwares, try polygott and install-pkg

HarperframeInc (454)

@21natzil Makes sense, who knows what we'll do with it?

abc3354 (229)

@HarperframeInc In fact, when you run a repl, you are in a kind of virtual machine, no way to escape it and to break replit ;)

firefish (954)

@abc3354 It's a docker container, look in /. You'll find .dockerenv


I know @firefish

BrianPadgett (1)

if / is also known as the default root directory as well as /root then why can i access / but not /root. su is locked by an unknown password and so is runner. ive tried to change permissions for the root directory but you cant. i tried it with all default directories. the only directories iv been able to even acess are /, /home, and /home/runner, and /home/runner/inheritance(this is one i created). i know i had accessed /root before but it was quite some time ago. could they have changed that abilty or did i do it just by accident. you cant access any root directories or files with root perms. man that sucks.

ironweb (1) is hosted in a docker container sotherecould be a way to escape it but most of the exploits have been. Patched im workingona new exploit


@ironweb sounds like trouble...

p.s. let me know when you find the exploit

jhash (9)

@ironweb If only there was an exploit. There is no way your finding one lol

WombleWoo7547 (0)

Yeah, I'm trying to use

sh -c "$(curl -fsSL"

to install "Oh My Bash" but it is prompting for password because it is accessing shell file. :(

BrianPadgett (1)

guys i dont know what i found but open this file and run the command aafire in the shell tab. expand the white box and right click. what is this?

fel1x0u (2)

@BrianPadgett haha lol i did some testing and theres also a Main.class


LouissPiouPiou (0)

cela devrait etre possible avec passwd