Skip to content
← Back to Community
Repl Not Running
Profile icon
MilkshakeCoder

Hi Replit Users,
I need some help, um, my program isnt running.

The Problem

replbeingweird

If you can see this gif, the repl run button changed for a hot-second, then went back to the static run button. It did not move or run the program, even though a .replit file was provided with run instructions for running the program.

Please tell me what to fix.

Voters
Profile icon
MilkshakeCoder
Comments
hotnewtop
Profile icon
KiranPatil8

#replrunissue

Profile icon
[deleted]

hi i recommend u do python bot.py or python3 bot.py

Profile icon
MilkshakeCoder

Heres an Update: Um, I deleted the repl and cloned from my existing git repo, still not working

Profile icon
CyberPy

So i forked your project and tried to find out your problem, but wasn't able to. Maybe it is just a glitch in replit, or it may be because of this reason:
There is no main.py file.
And which file do you wish to run?

Profile icon
MilkshakeCoder

@CodingEssence
my main file is called bot.py
but I specified that in the .replit file.

Profile icon
CyberPy

@MilkshakeCoder Oh, then nvm

Profile icon
InvisibleOne

I might be wrong, but I believe the .replit file should be python3 main.py
Or you could just remove the .replit file, as replit runs main.py be default

Profile icon
SixBeeps

What happens if you run the contents of the .replit run command directly in the Shell?

Profile icon
MilkshakeCoder

@SixBeeps
it makes me install a bunch of packages
and doesn't save them, so I still cant run it. I also cant add packages from the packages tab.

Profile icon
OldWizard209

try reloading the page, if that doesn't work, fork the repl and try it again.

Profile icon
MilkshakeCoder

@OldWizard209
i think i will delete my repl make a new one again