Ask coding questions

← Back to all posts
Python Help Poetry [SolverProblemError]
AlephNull101 (0)

I was trying to use pyrebase to connect to firebase storage, all of this worked fine on my python environment, with no troubles, i even went to the same lengths, and got the pip freeze from my pc, and install it through pip on the repository shell.

--> python3 -m poetry add validators youtube-dl firebase-admin flask pyrebase python-dotenv telegram
Using version ^0.18.2 for validators
Using version ^2021.5.16 for youtube-dl
Using version ^5.0.0 for firebase-admin
Using version ^2.0.1 for flask
Using version ^3.0.27 for pyrebase
Using version ^0.17.1 for python-dotenv
Using version ^0.0.1 for telegram

Updating dependencies
Resolving dependencies...

Because no versions of google-cloud-storage match >1.37.1,<1.38.0 || >1.38.0
 and google-cloud-storage (1.37.1) depends on requests (>=2.18.0,<3.0.0dev), google-cloud-storage (>=1.37.1,<1.38.0 || >1.38.0) requires requests (>=2.18.0,<3.0.0dev).
And because google-cloud-storage (1.38.0) depends on requests (>=2.18.0,<3.0.0dev), google-cloud-storage (>=1.37.1) requires requests (>=2.18.0,<3.0.0dev).
Because no versions of pyrebase match >3.0.27,<4.0.0
 and pyrebase (3.0.27) depends on requests (2.11.1), pyrebase (>=3.0.27,<4.0.0) requires requests (2.11.1).
Thus, pyrebase (>=3.0.27,<4.0.0) is incompatible with google-cloud-storage (>=1.37.1).
And because firebase-admin (5.0.0) depends on google-cloud-storage (>=1.37.1)
 and no versions of firebase-admin match >5.0.0,<6.0.0, pyrebase (>=3.0.27,<4.0.0) is incompatible with firebase-admin (>=5.0.0,<6.0.0).
So, because depends on both firebase-admin (^5.0.0) and pyrebase (^3.0.27), version solving failed.
exit status 1 Package operation failed.
AlephNull101 (0)

honestly frustrated with poetry, wish i could just remove it.