Skip to content
← Back to Community
Pygame code not running
Profile icon
KerttuOpe

Hi!
I'm having trouble running my pygame programs. Code that has worked before, now does not. This problem has persisted now for about 2 weeks.
Even simplest code won't run (import - - set_mode - - draw - - update - - sleep).
Additional print('something') works everywhere in the code, but nothing is animated.
Sorry for my bad language skills.
Hope someone can help

-Kerttu

image

Answered by Vandesm14 [earned 5 cycles]
View Answer
Voters
Profile icon
PeterApps
Profile icon
codemarble
Profile icon
LokeshJangra
Profile icon
JonathanWDavis
Profile icon
vismaypikachu
Profile icon
KerttuOpe
Comments
hotnewtop
Profile icon
Vandesm14

This is a known bug on repl.it: https://repl.it/bugs/p/pygame-not-working

Profile icon
KerttuOpe

@Vandesm14
Thank you for your reply. Is there any way round it, or do i need to create a new account?
-Kerttu

Profile icon
Vandesm14

@KerttuOpe It can not be fixed as of now. The only thing you can do is wait it out.

Profile icon
KerttuOpe

@Vandesm14 Thanks! Need to be patient, then...

Profile icon
Vandesm14

@KerttuOpe

Please mark my comment as the answer if I resolved your issue 👍

Profile icon
Yeetboi287

Not sure if this works all the time, but I had the same problem and I was able to fix it by changing the name of my project. The repl reloaded and started to work again. Hopefully this works for others.

Profile icon
22jbaird

@Yeetboi287 yeah that worked for me.

Profile icon
jellyhacker

@Yeetboi287 Absolute legend lad. Helped me out so much.

Profile icon
CarterAsh1

There is a way around this issue. When creating a new Repl, do NOT choose python as your language, choose '
Screen Shot 2020-09-23 at 12.31.19 PM
pygame'

This worked for me!

Profile icon
JonathanWDavis

I am having a similar problem except it is stuck at ".."

Profile icon
JonathanWDavis

@JonathanWDavis Nevermind I just started a new repl.it, but I have to do it everytime I do a change.

Profile icon
vismaypikachu

Same