Ask coding questions

← Back to all posts
Problem with tensorflow module
TheLostProgramm (1)

When running my code, it attempts to install tensorflow but then fails. Does anyone know how to help?

Error below:

Repl.it: Updating package configuration

--> python3 -m poetry add tensorflow tflearn
Using version ^2.4.1 for tensorflow
Using version ^0.5.0 for tflearn

Updating dependencies
Resolving dependencies...


Package operations: 2 installs, 0 updates, 0 removals

  - Installing tensorflow (2.4.1)

[EnvCommandError]
Command ['/opt/virtualenvs/python3/bin/pip', 'install', '--no-deps', 'tensorflow==2.4.1'] errored with the following return code 1, and output: 
Collecting tensorflow==2.4.1
  Downloading https://files.pythonhosted.org/packages/ac/9b/3fdbce9195fe53adbab1a930ee95a957af18c34a83ae5b1145f3cf8da409/tensorflow-2.4.1-cp38-cp38-manylinux2010_x86_64.whl (394.4MB)
ERROR: Could not install packages due to an EnvironmentError: [Errno 122] Disk quota exceeded

WARNING: You are using pip version 19.3.1; however, version 21.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

exit status 1


Repl.it: Package operation failed.
Comments
hotnewtop
AntimatterDev (35)

the problem its giving you is a disk quota exceeded. either its a error or your doing some huge project. the disk quota means that you have filled up all the space allowed in the area of the machine.

TheLostProgramm (1)

@AntimatterDev Thanks, I'll go upgrade so I can get more storage.