Skip to content
Sign upLog in
← Back to Community

Pip version problem !

Profile icon
AleksandrosPro1

Hi,
I had completed my first simple code for an assignment months ago, now that I have to write a report and etc about it, it needs to be ran few times. The issues is that, out of nowhere, from a working code, I get the following error all the time -

You are using pip version 9.0.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Here is a link to my code - https://repl.it/@AleksandrosPro1/DarkorchidShockingTransfer

Just to make it clear, I am fresh into programming in general.

Voters
Profile icon
AleksandrosPro1
Comments
hotnewtop
Profile icon
ash15khng

There isn't a big difference in the version actually, it shouldn't affect much. If you NEED to upgrade it, there's no solution to it sadly.

Profile icon
ArchieMaclean

There is nothing you can do about this - repl.it uses the old pip, and you can't upgrade it.

Profile icon
ArchieMaclean

@ArchieMaclean
It shouldn't actually cause any errors (the code should still work fine), it just means that some of the packages you are using may not be quite up to date.

Profile icon
JustA6

@ArchieMaclean
but i cant use my project bc of it

Profile icon
JustA6

@JustA6
it just doesn't run