Ask coding questions

← Back to all posts
Not able to install scrapy
KrishanuDhar (3)

Hi,

I am trying to install package scrapy (Ver 2.5.0), but has been running into a recursion error (pasted below). Any assistance to sort out this installation is appreciated.

Repl.it: Updating package configuration

--> python3 -m poetry add Scrapy
Using version ^2.5.0 for Scrapy

Updating dependencies
Resolving dependencies...

[RecursionError]
maximum recursion depth exceeded
exit status 1

Repl.it: Package operation failed.

Let me know if you have questions.
I think I saw a similar post in the forum, but without a conclusive resolution. Hence, re-initiating for support and guidance. Thank you!

Comments
hotnewtop
Coder100 (18148)

Did you accidentally edit the packager files? Delete them, and le replit regenerate them

KrishanuDhar (3)

@Coder100 I did that, but still same problem.