Ask coding questions

← Back to all posts
Node Versions
Crosis (281)

Hello fellow replers, many of you may have forgot about me by now, or not, but I have been developing something other than Gepl Chat. I have been making my own discord bot, Eternity, and have been using discord.js v12. I was wondering if there was any way to upgrade my node version, or if there was a way to using discord.js v13 in repl, as it is not compatible with the current node version repl has.

@RahulChoubey1
@GatewayDuckYT

Comments
hotnewtop
Coder100 (18109)

No cycle is better

Anyways use bash to run ur bot, the node language sucks.

Crosis (281)

@Coder100 What node version will bash run it in?

Crosis (281)

@Coder100 So if I make it in bash it will work?

piemadd (115)

I believe there is an update coming soon but I am unsure. What in Discord.js v13 do you need for you bot? Did you develop it on Replit?

Crosis (281)

@piemadd Discord.js v13 has a lot of features such as slash commands, integration, much more, but you need node v14 or higher for it. And yes, Eternity is developed on repl

piemadd (115)

@Crosis I see. Is it based on https://epic-bot.com/ at all by the way?

Crosis (281)

@piemadd The website is, not the bot. The website has nothing to do with the discord bot itself.