Ask coding questions

← Back to all posts
Maximum Recursion Depth Exceeded
AustinLeiwant (2)

I believe that this is a user error, and not a bug, that is why I am putting it here. I am making a discord bot, and it has worked fine up until this morning. I can't think of anything that I have changed that would have made it work differently. I dont know anything about "Maximum Recursion Depth", so some help here would be nice. This error happens right when I try to run the program, when it is installing packages. I then get "Package operation failed" error. If someone knows anything about this, help is appreciated.

Answered by Coder100 (17018) [earned 5 cycles]
View Answer
Comments
hotnewtop
Coder100 (17018)

probably something about this ^^

I recommend you deleting all the packager files

and then re-installing:

or just delete the package files and let repl.it handle it instead.

AustinLeiwant (2)

@Coder100 i get the same error that happens when i try to run the program when i try to uninstall packages.

Coder100 (17018)

wait did you not delete the packager files? pyproject.toml and poetry.lock? @AustinLeiwant

AustinLeiwant (2)

what are the packager files? @Coder100

Coder100 (17018)

i just told you, but they are these:

@AustinLeiwant

AustinLeiwant (2)

i dont know where to find the packager files @Coder100

Coder100 (17018)

they are on the bottom of your filelist @AustinLeiwant

AustinLeiwant (2)

i think this is working ill let you know if it does @Coder100

JuanPortal (0)

@Coder100 thanks, man! you've saved Jorgito (my bot)

SixBeeps (5062)

This looks like a bug in one of the packages you're using. Try hitting Ctrl+Shift+S and typing pip install discord into the bash window.

AustinLeiwant (2)

@SixBeeps when i do that shortcut, it just opens screencastify and nothing else. I am on a chromebook that could be the reason. I can try doing it on a windows computer if that would make a difference