Skip to content
← Back to Community
Installing package (RASA) requires different python version
Profile icon
travelmail26

I'm trying to install a python package for RASA, but i encounter an error

"Because no versions of rasa match >1.10.3,<2.0.0
and rasa (1.10.3) requires Python >=3.6,<3.8, rasa is forbidden.
So, because rasatest depends on rasa (^1.10.3), version solving failed.
exit status 1"

Is there a way to fix this on repl.it?

Voters
Profile icon
botovod
Profile icon
TheForArkLD
Profile icon
travelmail26
Comments
hotnewtop
Profile icon
ash15khng

You can't downgrade to older versions on repl.it, I think the only one you can do is Python 2. So there might not be a way to fix this?

Profile icon
CodeLongAndPros

You can -try- to run install-pkg python3.7 && python3.7 -m pip install rasa