Ask coding questions

← Back to all posts
Install-pkg does not work on some .deb packages
VictorGamer15 (1)

I tried installing 'hamachi.deb' using install-pkg, but when I tried executing 'hamachi' it says 'bash: hamachi: command not found'. What I could be doing wrong?

Comments
hotnewtop
Highwayman (1483)

ah. yeah no you can't manipulate anything other than the files in ~ and up, which is what hamachi is trying to do... so this can't work unless you can get it to work without being a daemon and such.

Highwayman (1483)

I'm pretty sure that just downloading the .deb file isn't the complete process to downloading an executable...? if you look in the logmein-hamachi-2.1.0.203-x64 directory you'll see an install.sh file, maybe try running that first?

programmeruser (604)

install-pkg only works for packages in the Ubuntu repos and URLs, not local files, though you could easily copy the script and modify it.

VictorGamer15 (1)

I already tried doing install-pkg https://vpn.net/installers/logmein-hamachi_2.1.0.203-1_amd64.deb, but it doesn't seem to work too

VictorGamer15 (1)

It's a .deb package, I cannot open it (I already tried), I have to install it